Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
zniekształcone wyświetlanie planszy gry Frozen Bubble
#1
0
Chciałbym zapytać o przyczynę i ewentualne rozwiązanie następującego problemu. Korzystam z Linux Mint  20 Ulyana. Po wydaniu polecenia uruchomienia gry wymienionej w temacie, pierwotna jej plansza wyświetla się we właściwych oryginalnych proporcjach, czyli 4×3. Jednak po wydaniu komendy ALt+F obraz gry nie zajmuje całego ekranu w prawidłowych proporcjach lecz następuje jego spłaszczenie w pionie. Inna gra jaką jest Rocks'n'Diamonds zachowuje się prawidłowo zachowując oryginalne proporcje planszy 4×3, niezależnie, czy uruchamiam planszę pierwotną, czy w pełnym ekranie. Dodam jeszcze, że na tym samym komputerze korzystam też z PCLinuxOS MATE i tam plansze obu rzeczonych gier zachowują oryginalną proporcję 4×3 niezazielenienie czy wydam komendę Alt+F czy nie.

Jaka może być przyczyna opisanej anomalii i czy da się ją jakoś wyeliminować?

Konfiguracja mojego sprzętu:

procesor: AMD Phenom II × 4 965
płyta główna: MSi 770-C45
pamięć operacyjna: 16 GB
karta grafiki: Zotac GT 730 Zone Edition 4GB
monitor: Dell 2007FP 1600x1200 IPS

Kod:
System:
  Kernel: 5.4.0-45-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
  Desktop: MATE 1.24.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Machine:
  Type: Desktop Mobo: MICRO-STAR model: 770-C45 (MS-7599) v: 1.0
  serial: <filter> BIOS: American Megatrends v: 1.13 date: 09/04/2010
CPU:
  Topology: Quad Core model: AMD Phenom II X4 965 bits: 64 type: MCP
  arch: K10 rev: 3 L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 27268
  Speed: 800 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: ZOTAC driver: nouveau
  v: kernel bus ID: 01:00.0
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1600x1200~60Hz, 1600x1200~60Hz
  OpenGL: renderer: NV106 v: 4.3 Mesa 20.0.8 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel
  v: kernel bus ID: 00:14.2
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ZOTAC driver: snd_hda_intel
  v: kernel bus ID: 01:00.1
  Device-3: vendor: Avermedia driver: N/A bus ID: 03:00.0
  Sound Server: ALSA v: k5.4.0-45-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Micro-Star MSI driver: r8169 v: kernel port: e800 bus ID: 04:00.0
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 232.89 GiB used: 16.40 GiB (7.0%)
  ID-1: /dev/sda vendor: Seagate model: ST250DM000-1BD141 size: 232.89 GiB
Partition:
  ID-1: / size: 112.89 GiB used: 16.40 GiB (14.5%) fs: ext4 dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 33.4 C mobo: N/A gpu: nouveau temp: 37 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 192 Uptime: 46m Memory: 15.64 GiB used: 1.24 GiB (7.9%)
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17
  inxi: 3.0.38
Odpowiedz
#2
0
Być może pomogłoby zainstalowanie i przełączenie sterownika GPU na Nvidię. Twoją kartę poprawnie powinien obsługiwać starszy sterownik - 390. Sprawdź, czy w Menu -> Administracja -> Zarządzanie sterownikami masz propozycję instalacji tego sterownika.
Jeśli będzie, zainstalujesz, ale po restarcie komputera zastaniesz czarny ekran, uruchom ponownie komputer, wyświetl menu GRUB i wybierz opcje zaawansowane. Stąd uruchom tryb recovery, wybierz wiersz poleceń administratora.
Polecenie do usunięcia sterownika Nvidii to: apt-get purge nvidia* a restart komputera to 'reboot`. Po tym system powinien uruchomić się prawidłowo znów na sterowniku nouveau.
Odpowiedz
#3
0
(07-09-2020, 21:40)yahoob3 napisał(a): Być może pomogłoby zainstalowanie i przełączenie sterownika GPU na Nvidię. Twoją kartę poprawnie powinien obsługiwać starszy sterownik - 390. Sprawdź, czy w Menu -> Administracja -> Zarządzanie sterownikami masz propozycję instalacji tego sterownika.
Jeśli będzie, zainstalujesz, ale po restarcie komputera zastaniesz czarny ekran, uruchom ponownie komputer, wyświetl menu GRUB i wybierz opcje zaawansowane. Stąd uruchom tryb recovery, wybierz wiersz poleceń administratora.
Polecenie do usunięcia sterownika Nvidii to: apt-get purge nvidia* a restart komputera to 'reboot`. Po tym system powinien uruchomić się prawidłowo znów na sterowniku nouveau.
Nie jestem biegły w tych sprawach, Załączam zatem zrzut ekranu, który ukazał się po wydaniu zasugerowanego polecenia. Czy na tej liście znajduje się opcja, której wybór dałby szansę na zażegnanie problemu? Czy w takim przypadku ponowne uruchomienie systemu nastąpi w zwykły sposób?


Załączone pliki Miniatury
   
Odpowiedz
#4
0
Wybierz pierwszy od góry sterownik na liście.
Odpowiedz
#5
0
(08-09-2020, 08:05)dedito napisał(a): Wybierz pierwszy od góry sterownik na liście.
Spróbuję wkrótce. Czy po tym wyborze system uruchomi się normalnie, czy też trzeba się liczyć z ryzykiem jakichś komplikacji?
Odpowiedz
#6
0
Nikt nie da takich gwarancji, w razie czego trzeba będzie wrócić do starego z trybu ratunkowego.
Odpowiedz
#7
0
(08-09-2020, 08:21)dedito napisał(a): Nikt nie da takich gwarancji, w razie czego trzeba będzie wrócić do starego z trybu ratunkowego.
Czy tryb ratunkowy w razie niepowodzenia uruchamia się automatycznie, czy też wymaga to określonego postępowania?
Odpowiedz
#8
0
Opisałem to postępowanie w tym poście: https://forum.linuxmint.pl/showthread.ph...62#pid9162
Jeśli menu GRUB (wybór systemu podczas uruchamiania komputera) nie wyświetla się, tuż po uruchomieniu komputera wciśnij i przytrzymaj klawisz Shift (lub Esc - w zależności od komputera) do chwili pojawianie się tego menu. Potem postępuj tak, jak pisałem w linkowanym poście.

Spróbuj tego sterownika, o którym pisał @dedito. Instalacja za pomocą menedżera sterowników, to tylko jedno kliknięcie i restart komputera po zakończeniu instalacji.
Odpowiedz
#9
0
(08-09-2020, 14:13)?yahoob3 napisał(a): Opisałem to postępowanie w tym poście: https://forum.linuxmint.pl/showthread.ph...62#pid9162
Jeśli menu GRUB (wybór systemu podczas uruchamiania komputera) nie wyświetla się, tuż po uruchomieniu komputera wciśnij i przytrzymaj klawisz Shift (lub Esc - w zależności od komputera) do chwili pojawianie się tego menu. Potem postępuj tak, jak pisałem w linkowanym poście.

Spróbuj tego sterownika, o którym pisał @dedito. Instalacja za pomocą menedżera sterowników, to tylko jedno kliknięcie i restart komputera po zakończeniu instalacji.
Wybrałem ten sterownik. System wprawdzie uruchomił się ponownie, lecz powstał kolejny problem.  Otóż pulpit pozbawiony jest teraz paska zadań. co uniemożliwia mi skorzystania z menu.
W jaki sposób przywrócić utraconą funkcjonalność?
Odpowiedz
#10
0
Spróbuj wcisnąć F2 i okienku tam wpisz mate-terminal lub kliknij PPM na pulpicie i powinna być opcja otwarcia termianala.
W terminalu wpisz mate-panel --replace
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: lukand, 1 gości