Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Ręczna aktualizacja systemu
#1
0
Jeśli chcemy spowodować, aby system miał wyłączoną "automatyczną aktualizację, to wchodzimy w "Parametry" - "Secja i uruchamianie" i na trzeciej zakładce mamy możliwość wyłączenia pewnych funkcji uruchamianych w autostarcie.
[Obrazek: ZOQh6ntl.png]
Ja u siebie wyłączyłem i co dwa lub trzy dni z konsoli uruchamiam sprawdzanie aktualizacji

Kod:
sudo apt update && sudo apt upgrade
Dlaczego to piszę, bo autoaktualizacja jeśli jest włączona i niczego do "zaktualizowania' nie pokazuje - to i tak wpisując powyższe polecenie z konsoli wielokrotnie zasysało u mnie aktualizacje.
Odpowiedz
#2
0
To jest forum polskie, dlatego prosimy wstawiać zrzuty po polsku.
Proszę też zauważyć, że piszesz w dziale LMDE.
Poza tym wyłączanie tej funkcji nie jest dobrym pomysłem.
Odpowiedz
#3
0
(19-04-2019, 06:55)dedito napisał(a): To jest forum polskie, dlatego prosimy wstawiać zrzuty po polsku.
Proszę też zauważyć, że piszesz w dziale LMDE.
Poza tym wyłączanie tej funkcji nie jest dobrym pomysłem.
Przecież ja piszę po polsku. Zrzuty moga być (byc może) w innych językach (nie widziałem tego w regulaminie) z opisem po polsku. Na codzień pracuje w Mincie po ferancusku i "czasem tylko" zamieniam na polski. Nie będę się upierał "czy to dobre czy złe" wyłączenie tej funkcji.
Ja u siebie wyłączyłem, bo zauważyłem że i tak ta "automatyczna funkcja" nie wyłapuje wszystkiego. Dlatego też opisałem moje ustawienia.
Odpowiedz
#4
0
Bo ta funkcja odświeża w określonych (patrz właściwości menadżera aktualizacji, zakładka autoodświeżanie) interwałach czasowych.
Odpowiedz
#5
0
Poza tym, apt upgrade ciągnie wszystkie paczki w najnowszych wersjach, co może prowadzić do problemów (vide Ubuntu). Zaznaczenie dwóch pierwszych poziomów aktualizacji w Mincie daje praktycznie 100% pewność, że po upgradzie problemów nie będzie. Piszę to z autopsji. Najnowszych paczek nie potrzebuję, bo co mam zrobić, to zrobię na tym co jest. Pogoń za numerkami "dobra" dla ogarniętych testerów, a nie zwykłych użytkowników.

@lcojote, zrzuty po francusku są mało pomocne, nawet opisane, bo ilu użytkowników tego forum posługuję się taka wersją? Jeden? Smile Językiem IT jednak jest i chyba będzie Inglisz Smile
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Odpowiedz
#6
0
(19-04-2019, 13:54)yahoob3 napisał(a): Poza tym, apt upgrade ciągnie wszystkie paczki w najnowszych wersjach, co może prowadzić do problemów (vide Ubuntu). Zaznaczenie dwóch pierwszych poziomów aktualizacji w Mincie daje praktycznie 100% pewność, że po upgradzie problemów nie będzie. Piszę to z autopsji. Najnowszych paczek nie potrzebuję, bo co mam zrobić, to zrobię na tym co jest. Pogoń za numerkami "dobra" dla ogarniętych testerów, a nie zwykłych użytkowników.

@lcojote, zrzuty po francusku są mało pomocne, nawet opisane, bo ilu użytkowników tego forum posługuję się taka wersją? Jeden? Smile Językiem IT jednak jest i chyba będzie Inglisz Smile
OK już się poprawiłem i jak będę robił zrzuty to przejdę na Polonaise Langue. Wiadomo, że językiem IT jest i pozostanie English.
Tutaj nawet bios/UEFI jest po angielsku i francusku. Ale ja przestawiam na English
Odpowiedz
#7
0
apt upgrade jest akurat bezpieczne.
Problemów można się spodziewać przy full-upgrade
Cytat:upgrade (apt-get(8))
          upgrade is used to install available upgrades of all packages
          currently installed on the system from the sources configured via
          sources.list(5). New packages will be installed if required to
          satisfy dependencies, but existing packages will never be removed.
          If an upgrade for a package requires the removal of an installed
          package the upgrade for this package isn't performed.

      full-upgrade (apt-get(8))
          full-upgrade performs the function of upgrade but will remove
          currently installed packages if this is needed to upgrade the
          system as a whole.
Ja mam testinga i zawsze robię full-upgrade.
Od czasu do czasu są jakieś problemy, ale daję sobie z nimi radę.
Odpowiedz
#8
0
OK, ale jak wytłumaczyć fakt, że 'drugi poziom automatu' nie pokazuje nic, a upgrade chce pobrać u mnie dodatkowe 44 aktualizacje i 155 MB danych?
Ciekawy już byłem, teraz zostało mi tylko lenistwo Wink
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Odpowiedz
#9
0
(19-04-2019, 22:30)yahoob3 napisał(a): OK, ale jak wytłumaczyć fakt, że 'drugi poziom automatu' nie pokazuje nic, a upgrade chce pobrać u mnie dodatkowe 44 aktualizacje i 155 MB danych?
Ciekawy już byłem, teraz zostało mi tylko lenistwo Wink

Powód jest prozaiczny? Minta nikt z "power userów" (poza tobą oczywiście) nie używa i mało kto orientuje się w niuansach miętowego Menadżera Aktualizacji.
Burble, Burble, Burble ... hahaaaaaaa Big Grin 
Odpowiedz
#10
0
Z tego co wyczytałem poziom 5 jest wciąż bezpieczniejszy od apt upgrade, i to by była odpowiedź na pytania yahoob3 i lcoyote, dlaczego są takie różnice w paczkach do aktualizacji.
Na pewno jest to temat, który muszę jeszcze zgłębić.

No ja tak nie do końca nie używam Minta. Na laptopie mam LMDE i Minta, dodatkowo na wirtualce mam kolejnego Minta.
Są to dla mnie, co prawda, systemy "z doskoku", żeby coś przetestować, czy upewnić się jak coś działa, także może i nie używam, ale czasem coś tam porobię.

Poziomy zabezpieczeń menadżera zostały wyjaśnione m.in. tutaj: https://sites.google.com/site/easytipsfo...-explained
Cytat:The 5 levels and their description are:

Level 1:
Certified packages. These packages has been tested or directly maintained by Linux Mint. Recommended to be updated when updates are available.

Level 2:
Recommended packages. All packages are tested and approved by Linux Mint. Also recommended to be updated.

Level 3:
Safe packages. All level 3 packages are not tested but considered to be safe. Recommended to be updated as well.

Level 4:
Unsafe packages. Updates classified as level 4 could have a potential negative affect on system stability. Deselected by default for safety and visibility.

Level 5: Dangerous packages. Updates classified as level 5 can have a negative affect on system stability depending on the system hardware and specifications. Also deselected for safety and visibility.
Although there are users who claim that level 4 and level 5 updates disrupt their systems when it comes to stability, there are plenty of users who select level 4 and level 5 for updating and not having any problems with their system after updating.

Tip:
At the bottom of the Update Manager preferences menu, there are 2 options visible. The first option is selected by default. However, the second option is not selected. It is handy to select the second option as well.

Option 1 (selected by default):
Always show security updates

Option 2 (deselected by default):
Always select and trust security updates
Z tego powodu co innego pokazuje menadżer aktualizacji, co innego apt, apt-get, aptitude.
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości