Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Screen Tearing na Laptopie
#1
0
Mam problem z rozchodzącym/rozrywającym się obrazem (tzw. screen tearing), kiedy zainstaluje sterownik karty graficznej od nVidii z Menadżera Sterowników "Driver Manager". Z tego powodu korzystam z otwartoźródłowego sterownika "X.Org X server -- Nouvea display driver", jednak obsługuje on jedynie moją kartę zintegrowaną w procesorze przez co nawet najprostsze gry jak SuperTuxKart nie chodzą płynnie. 
Dedykowany sterownik nVidii nie ma opcji “Force Composition Pipeline”

Moja konfiguracja sprzętowa:
Kod:
System:
 Host: G70_80 Kernel: 4.15.0-47-generic x86_64 bits: 64 compiler: gcc
 v: 7.3.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
 base: Ubuntu 18.04 bionic
Machine:
 Type: Laptop System: LENOVO product: 80FF v: Lenovo G70-80
 serial: <filter>
 Mobo: LENOVO model: Lenovo G70-80 v: NO DPK serial: <filter>
 UEFI [Legacy]: LENOVO v: ABCN80WW date: 05/18/2015
CPU:
 Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP
 arch: Broadwell rev: 4 L2 cache: 3072 KiB
 flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17559
 Speed: 1072 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 798
 3: 798 4: 798
Graphics:
 Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
 bus ID: 00:02.0
 Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Lenovo driver: nouveau
 v: kernel bus ID: 04:00.0
 Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau
 unloaded: fbdev,vesa resolution: 1600x900~60Hz
 OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
 v: 4.5 Mesa 18.2.8 direct render: Yes
Info:
 Processes: 240 Uptime: 15h 00m Memory: 7.71 GiB used: 3.72 GiB (48.3%)
 Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19
 inxi: 3.0.27

Ja się już prawie poddałem screen tearingowi, może  Wy coś pomożecie, byłbym bardzo wdzięczny.


Używaj znaczników code - https://forum.linuxmint.pl/showthread.ph...d=33#pid33
Odpowiedz
#2
0
Spróbuj dodać taką komendę jak nie masz tego w menu nvidii:
Kod:
nvidia-settings --assign CurrentMetaMode="$(xrandr | sed -nr '/(\S+) connected (primary )?[0-9]+x[0-9]+(\+\S+).*/{ s//\1: nvidia-auto-select \3 { ForceCompositionPipeline = On }, /; H }; ${ g; s/\n//g; s/, $//; p }')"
Odpowiedz
#3
0
Dzięki, ale niestety nie podziałało, dalej screen tearing na dedykowanej karcie.
Odpowiedz
#4
1
Better response on post RE: Screen Tearing na LaptopieZnalazłem coś takiego. Ja nie mam takiego srodowiska graficznego więc nie mogę tego sprawdzić.

https://winaero.com/blog/cinnamon-4-0-re...n-tearing/
Odpowiedz
#5
0
...a wynik tego

Kod:
cat /var/log/Xorg.0.log|pastebinit
Burble, Burble, Burble ... hahaaaaaaa Big Grin 
Odpowiedz
#6
0
Dziękuję Pawlik. Znalazłem rozwiązanie dla mojego Screen Tearing, z ktorym męczyłem się od bardzo dawna. Podaja rozwiązanie do sprawdzenia, bo nie jestem biegły w Linuxie. 
1. Menu=> System Settings > Preferences > General 
Wyłączam opcję "Enable VBlank (Requires Cinnamon restart"
Następnie restartuje system. 
2. Otwieram Terminal skrótem Ctrl+Alt+t i wpisuje 
Kod:
sudo nano /etc/modprobe.d/zz-nvidia-modeset.conf
Następnie dodaję treść:

Kod:
options nvidia_drm modeset=1

Zapisuje skrótem Ctrl+s i wychodzę Ctrl+x

3. Wpisuję do terminala 

Kod:
sudo update-initramfs -u

I restartuje komputer.

Screen Tearing powinien zniknąć.
Źródła:
https://forums.linuxmint.com/viewtopic.php?t=277267
https://www.cmscritic.com/stop-screen-te...-in-linux/

Nie biorę odpowiedzialności za to rozwiązanie, bo jak już wspomniałem nie jestem biegły w Linuxie, ale mi pomogło.
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości