Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Solved WiFi Lenovo Z500 - bardzo wolno działa
#1
0
Cześć. Witam wszystkich na linuksiarzy Smile

Będę wdzięczny za pomoc w rozwiązaniu problemu z bardzo wolno działającym połączeniem Wifi.
Lenovo Z500, i7, 16GB RAM - połaczenie z netem działa bardzo wolno.
2 systemy: Mint 19.1 + Windows
Pod windą wszystko działa OK.
Instalacja Linuksa przebiegała bardzo długo - repozytoria ściągały się, jak "krew z nosa".
Ponieważ dopiero poznają linuksa, jestem zielony, jak "szczypior na wiosnę". Szukałem info w necie, ale nie udało mi się znaleźć rozwiązania.
Będę wdzięczny za pomoc Smile

lspci -k
Kod:
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
Subsystem: Lenovo 3rd Gen Core processor DRAM Controller
Kernel driver in use: ivb_uncore
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Subsystem: Lenovo 3rd Gen Core processor Graphics Controller
Kernel driver in use: i915
Kernel modules: i915
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
Subsystem: Lenovo 7 Series/C210 Series Chipset Family USB xHCI Host Controller
Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
Subsystem: Lenovo 7 Series/C216 Chipset Family MEI Controller
Kernel driver in use: mei_me
Kernel modules: mei_me
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
Subsystem: Lenovo 7 Series/C216 Chipset Family USB Enhanced Host Controller
Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
Subsystem: Lenovo 7 Series/C216 Chipset Family High Definition Audio Controller
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
Subsystem: Lenovo 7 Series/C216 Chipset Family USB Enhanced Host Controller
Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
Subsystem: Lenovo HM76 Express Chipset LPC Controller
Kernel driver in use: lpc_ich
Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
Subsystem: Lenovo 7 Series Chipset Family 6-port SATA Controller [AHCI mode]
Kernel driver in use: ahci
Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
Subsystem: Lenovo 7 Series/C216 Chipset Family SMBus Controller
Kernel driver in use: i801_smbus
Kernel modules: i2c_i801
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 05)
Subsystem: Lenovo RTL810xE PCI Express Fast Ethernet controller
Kernel driver in use: r8169
Kernel modules: r8169
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
Subsystem: Intel Corporation Centrino Wireless-N 2230 BGN
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi
Odpowiedz
#2
0
Próbowałeś takiego rozwiązania? Dopisanie opcji w pliku iwlwifi.conf i ponowne uruchomienie.


Kod:
echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf
Burble, Burble, Burble ... hahaaaaaaa Big Grin 
Odpowiedz
#3
0
Spróbuj dopisać opcję do sterownika:
echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf
Ewentualnie potestuj inne działania opisane tutaj http://forums.debian.net/viewtopic.php?f=16&t=121696
Odpowiedz
#4
0
Dzięki serdeczne. Zadziałało Smile
Kod:
echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

Teraz aktualizacja trwa 2 minuty, a nie 3 godz., jak wcześniej wyskakiwało info Smile
... no i mogę wreszcie pisać przez Linuksa, a nie przełączać się między systemami, aby skorzystać z neta.

Pozdrawiam Smile


P.S.
Ponieważ co jakiś czas internet niestety zwalniał, przeinstalowałem kolejny raz sterowniki:
Kod:
sudo apt-get install --reinstall linux-firmware
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

Ponownie wpisałem komendę:
Kod:
echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

Z tego co doczytałem, to chyba wyłączenie kanału N w karcie Wifi.


Nie rozumiem, co się dzieje. Raz jest OK i ping poniżej 20ms, a czasem powyżej 60ms.
Prędkość raz powyżej 30MBit/s, częściej poniżej 200Bit/s.
Wygląda to tak, jakby losowo instalował lub deinstalował się jakiś sterownik.
Włączałem/wyłączałem zaporę (teraz jest wyłączona).

Niestety, o ile ping w speedtest.net mam poniżej 30ms, to prędkość transferu poniżej 300 Bit/s (0,300 MBit/s)
Powyższe zmiany zadziałały na chwilę lub nie zadziałały.

Zmieniłem jądro Linuxa z 4.15 na 4.18 (skorzystałem z Menadżera aktualizacji).

Obecnie modem działa poprawnie, tj. ping poniżej 30ms i prędkość porównywalana do transferu w windowsie.
Ping dla mnie satysfakcjonujący - korzystam z LTE.

Być może komuś przyda się podpowiedź ze zmianą kernela.
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości