Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Przełączenie output na hdmi
#1
0
Próbowałem zmienić wyjście audio na hdmi wg tego poradnika yahooba https://forum.linuxmint.pl/showthread.php?tid=254, ale nie widzę hdmi na liście moich outputów albo nie jestem w stanie go zidentyfikować. Co można z tym zrobić? Obecnie mam analog stereo z wbudowanych głośników, komenda wykonana przy podpiętym pod telewizor kablu hdmi, obraz jest. 

Kod:
rrico@rrico-GV72-8RE:~$ pactl list cards
0. karta
Nazwa: alsa_card.pci-0000_00_1f.3
Sterownik: module-alsa-card.c
Właściciel modułu: 7
Właściwości:
alsa.card = "0"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0xa4310000 irq 141"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1f.3"
sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "a348"
device.form_factor = "internal"
device.string = "0"
device.description = "Wbudowany dźwięk"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
Profile:
input:analog-stereo: Wejście Analogowe stereo (odpływy: 0, źródła: 1, priorytet: 60, dostępne: tak)
output:analog-stereo: Wyjście Analogowe stereo (odpływy: 1, źródła: 0, priorytet: 6000, dostępne: tak)
output:analog-stereo+input:analog-stereo: Analogowy dupleks stereo (odpływy: 1, źródła: 1, priorytet: 6060, dostępne: tak)
output:analog-surround-21: Wyjście Analogowe przestrzenne 2.1 (odpływy: 1, źródła: 0, priorytet: 800, dostępne: tak)
output:analog-surround-21+input:analog-stereo: Wyjście Analogowe przestrzenne 2.1 + Wejście Analogowe stereo (odpływy: 1, źródła: 1, priorytet: 860, dostępne: tak)
output:analog-surround-40: Wyjście Analogowe przestrzenne 4.0 (odpływy: 1, źródła: 0, priorytet: 700, dostępne: tak)
output:analog-surround-40+input:analog-stereo: Wyjście Analogowe przestrzenne 4.0 + Wejście Analogowe stereo (odpływy: 1, źródła: 1, priorytet: 760, dostępne: tak)
output:analog-surround-41: Wyjście Analogowe przestrzenne 4.1 (odpływy: 1, źródła: 0, priorytet: 800, dostępne: tak)
output:analog-surround-41+input:analog-stereo: Wyjście Analogowe przestrzenne 4.1 + Wejście Analogowe stereo (odpływy: 1, źródła: 1, priorytet: 860, dostępne: tak)
output:analog-surround-50: Wyjście Analogowe przestrzenne 5.0 (odpływy: 1, źródła: 0, priorytet: 700, dostępne: tak)
output:analog-surround-50+input:analog-stereo: Wyjście Analogowe przestrzenne 5.0 + Wejście Analogowe stereo (odpływy: 1, źródła: 1, priorytet: 760, dostępne: tak)
output:analog-surround-51: Wyjście Analogowe przestrzenne 5.1 (odpływy: 1, źródła: 0, priorytet: 800, dostępne: tak)
output:analog-surround-51+input:analog-stereo: Wyjście Analogowe przestrzenne 5.1 + Wejście Analogowe stereo (odpływy: 1, źródła: 1, priorytet: 860, dostępne: tak)
output:iec958-stereo: Wyjście Cyfrowe stereo (IEC958) (odpływy: 1, źródła: 0, priorytet: 5500, dostępne: tak)
output:iec958-stereo+input:analog-stereo: Wyjście Cyfrowe stereo (IEC958) + Wejście Analogowe stereo (odpływy: 1, źródła: 1, priorytet: 5560, dostępne: tak)
off: Wyłączone (odpływy: 0, źródła: 0, priorytet: 0, dostępne: tak)
Aktywny profil: output:analog-stereo+input:analog-stereo
Porty:
analog-input-internal-mic: Wewnętrzny mikrofon (priority: 8900, latency offset: 0 usec)
Właściwości:
device.icon_name = "audio-input-microphone"
Część profilu: input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-21+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:iec958-stereo+input:analog-stereo
analog-input-mic: Mikrofon (priority: 8700, latency offset: 0 usec, not available)
Właściwości:
device.icon_name = "audio-input-microphone"
Część profilu: input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-21+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:iec958-stereo+input:analog-stereo
analog-output-speaker: Głośniki (priority: 10000, latency offset: 0 usec)
Właściwości:
device.icon_name = "audio-speakers"
Część profilu: output:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-21, output:analog-surround-21+input:analog-stereo, output:analog-surround-40, output:analog-surround-40+input:analog-stereo, output:analog-surround-41, output:analog-surround-41+input:analog-stereo, output:analog-surround-50, output:analog-surround-50+input:analog-stereo, output:analog-surround-51, output:analog-surround-51+input:analog-stereo
analog-output-headphones: Słuchawki (priority: 9000, latency offset: 0 usec, not available)
Właściwości:
device.icon_name = "audio-headphones"
Część profilu: output:analog-stereo, output:analog-stereo+input:analog-stereo
iec958-stereo-output: Wyjście cyfrowe (S/PDIF) (priority: 0, latency offset: 0 usec)
Część profilu: output:iec958-stereo, output:iec958-stereo+input:analog-stereo
-------------
MSi GV72-8RE | Mint 19.1 | 4.15.0-47-generic x86_64 | Mate 1.20.1 | Nvidia GeForce GTX 1060
Odpowiedz
#2
0
Cześć

W alsamixer masz wszystkie SPDIF'y powłączane?
Pokaż aplay -l .
pavucontrol zainstalowane?
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Nikt mi nie wmówi, że 19.1 jest już OK. Dałem jej tydzień - wyleciała z hukiem. To jeszcze nie jest system na produkcję. Howgh
Odpowiedz
#3
0
Alsa: mike i headphones na 0, reszta na 100

aplay -l:
Kod:
**** Lista PLAYBACK urządzeń ****
karta 0: PCH [HDA Intel PCH], urządzenie 0: ALC892 Analog [ALC892 Analog]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: PCH [HDA Intel PCH], urządzenie 1: ALC892 Digital [ALC892 Digital]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0

Pavucontrol: dostępne wyjścia - słuchawki albo głośniki i nie ma innego albo, poziom ustawiony na 100% (czyli jak zwykle kiedy coś robię)
-------------
MSi GV72-8RE | Mint 19.1 | 4.15.0-47-generic x86_64 | Mate 1.20.1 | Nvidia GeForce GTX 1060
Odpowiedz
#4
0
Wygląda jakbyś nie miał zainstalowanego HDMI...?
Pokaż jeszcze aplay -L, może ilin zerknie jak wpadnie - ja nic nie mogę wyguglać. Jest tego dużo, ale urządzenie jest, a tylko dźwięku nie ma. U ciebie jak na moje oko to nic nie ma...


Nie byłeś wtedy na Mazurach z tym laptopem? Big Grin
Mint 18.3 Cinnamon, kern. 4.10; 64-bit na: Lenovo G500S z CPU Pent. 2020M 2.4 GHz*2; 6 GB RAM; GPU Intel+GeForce 720M; LU#586742
Nikt mi nie wmówi, że 19.1 jest już OK. Dałem jej tydzień - wyleciała z hukiem. To jeszcze nie jest system na produkcję. Howgh
Odpowiedz
#5
0
Kod:
rrico@rrico-GV72-8RE:~$ aplay -L
default
   Playback/recording through the PulseAudio sound server
null
   Discard all samples (playback) or generate zero samples (capture)
pulse
   PulseAudio Sound Server
sysdefault:CARD=PCH
   HDA Intel PCH, ALC892 Analog
   Default Audio Device
front:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   Front speakers
surround21:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Digital
   IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   Direct sample mixing device
dmix:CARD=PCH,DEV=1
   HDA Intel PCH, ALC892 Digital
   Direct sample mixing device
dsnoop:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   Direct sample snooping device
dsnoop:CARD=PCH,DEV=1
   HDA Intel PCH, ALC892 Digital
   Direct sample snooping device
hw:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   Direct hardware device without any conversions
hw:CARD=PCH,DEV=1
   HDA Intel PCH, ALC892 Digital
   Direct hardware device without any conversions
plughw:CARD=PCH,DEV=0
   HDA Intel PCH, ALC892 Analog
   Hardware device with all software conversions
plughw:CARD=PCH,DEV=1
   HDA Intel PCH, ALC892 Digital
   Hardware device with all software conversions

Na Mazurach nie miałem sprzęta, tam nawet ze zwykłym prądem były klocki Smile

No właśnie się zdziwiłem bo nie widzę na wyjściu hdmi i nie wiem czemu. IEC nic tu nie pomoże? Obraz po kablu przechodzi normalnie czyli port jako taki działa.
-------------
MSi GV72-8RE | Mint 19.1 | 4.15.0-47-generic x86_64 | Mate 1.20.1 | Nvidia GeForce GTX 1060
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości