Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
System nie wykrywa podłączonych słuchawek
#1
0
Witam, chciałbym sobie podłączyć słuchawki, ale nie wiem, dlaczego system mi słuchawek nie wykrywa, jak i przodu komputera i z tyłu. Na innych urządzeniach słuchawki są prawidłowo wykrywane. Używam Minta ze środowiskiem Xfce. Czego może być wina mojego sprzętu, czy systemu, czy brak zainstalowanego potrzebnego oprogramowania?? [Obrazek: Mzm5hzR.png]


Z dźwiękiem w głośnikach nie ma problemu, głośniki mam wbudowane.

Kod:
System:    Host: dudosek-HP-Compaq-6200-Pro-SFF-PC Kernel: 5.0.0-37-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
           Desktop: Xfce 4.14.1 Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic
Machine:   Type: Desktop System: Hewlett-Packard product: HP Compaq 6200 Pro SFF PC v: N/A serial: <filter>
           Mobo: Hewlett-Packard model: 1497 serial: <filter> UEFI: Hewlett-Packard v: J01 v02.15 date: 11/10/2011
CPU:       Topology: Dual Core model: Intel Pentium G850 bits: 64 type: MCP arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11573
           Speed: 1683 MHz min/max: 1600/2900 MHz Core speeds (MHz): 1: 1840 2: 1771
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Hewlett-Packard driver: i915
           v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1280x1024~75Hz
           OpenGL: renderer: Mesa DRI Intel Sandybridge Desktop v: 3.3 Mesa 19.0.8 direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel
           v: kernel bus ID: 00:1b.0
           Sound Server: ALSA v: k5.0.0-37-generic
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k port: f080
           bus ID: 00:19.0
           IF: eno1 state: down mac: <filter>
           Device-2: Atheros AR9271 802.11n type: USB driver: ath9k_htc bus ID: 1-1.2:3
           IF: wlx18a6f71397c9 state: up mac: <filter>
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives:    Local Storage: total: 465.76 GiB used: 95.08 GiB (20.4%)
           ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-08U6AA0 size: 465.76 GiB
Partition: ID-1: / size: 456.96 GiB used: 95.08 GiB (20.8%) fs: ext4 dev: /dev/sda2
Sensors:   System Temperatures: cpu: 36.0 C mobo: N/A                                                                                                        
           Fan Speeds (RPM): N/A                                                                                                                              
Info:      Processes: 192 Uptime: 9m Memory: 3.74 GiB used: 1.55 GiB (41.3%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0                                  
           Shell: bash v: 4.4.20 inxi: 3.0.32
Odpowiedz
#2
0
Uruchom terminal i wpisz w nim alsamixer - powinien uruchomić się program do zarządzania dźwiękiem. Popatrz czy tam nie można czegoś ustawić. Poruszasz się strzałkami, klawisz M wycisza/wyłącza wyciszenie...
Coś jak to:
[Obrazek: CqdLcdLl.png]

W systemowym programie poklikaj na ten głośniczek...
[Obrazek: 7KmiWn7l.png]
Odpowiedz
#3
0
(07-01-2020, 22:16)yahoob3 napisał(a): Uruchom terminal i wpisz w nim alsamixer - powinien uruchomić się program do zarządzania dźwiękiem. Popatrz czy tam nie można czegoś ustawić. Poruszasz się strzałkami, klawisz M wycisza/wyłącza wyciszenie...
Coś jak to:
[Obrazek: CqdLcdLl.png]

W systemowym programie poklikaj na ten głośniczek...
[Obrazek: 7KmiWn7l.png]
 

Próbowałem w alsamixerze i podłączyłem znów słuchawki i nic to nie dało. Zastanawiam się, czy nie sprawdzić innej dystrybucji w formie live. A jack w słuchawkach ma 3 kontakty.
Odpowiedz
#4
0
Sprawdź sprawność tych słuchawek i tego wejścia, inna dystrybucja też nie zawadzi.
Te nowe laptopy mają już chyba w większości jedno gniazdo na mikrofon i głośniki, ale to chyba jest kompatybilne ze zwykłymi słuchawkami stereo.
Odpowiedz
#5
0
(08-01-2020, 19:07)dedito napisał(a): Sprawdź sprawność tych słuchawek i tego wejścia, inna dystrybucja też nie zawadzi.
Te nowe laptopy mają już chyba w większości jedno gniazdo na mikrofon i głośniki, ale to chyba jest kompatybilne ze zwykłymi słuchawkami stereo.
Dziwne jest to, że tylko wyłącznie na stacjonarce nie jest wykrywany. Zamierzam pobrać dla odmiany inną dystrubucje by to sprawdzić.

Odpowiedz
#6
0
Można jeszcze zainstalować program do zarządzania alsą:
Kod:
sudo apt install alsa-plugins
sudo apt-get install alsa-tools-gui
i tu pobawić się ustawieniami - zwłaszcza HDAJack Retask i ustawieniem wyjść.
Może pomoże.
Odpowiedz
#7
0
(08-01-2020, 20:03)yahoob3 napisał(a): Można jeszcze zainstalować program do zarządzania alsą:
Kod:
sudo apt install alsa-plugins
sudo apt-get install alsa-tools-gui
i tu pobawić się ustawieniami - zwłaszcza HDAJack Retask i ustawieniem wyjść.
Może pomoże.

Działa, lecz tylko gra wiele ciszej i wyłącznie z tyłu komputera.
Odpowiedz
#8
0
A jakieś inne słuchawki próbowałeś do tego komputera podłączyć? Np. od telefonu - te z 4 pinami?
Odpowiedz
#9
0
(08-01-2020, 20:34)yahoob3 napisał(a): A jakieś inne słuchawki próbowałeś do tego komputera podłączyć? Np. od telefonu - te z 4 pinami?
Niestety nie posiadam takich słuchawek a te, które mam były dołączone od samsunga przy zakupie mojego obecnego smartfona od Samsunga, oraz tylko jedna słuchawka gra.
Odpowiedz
#10
0
HDA Jack Retask po zaznaczeniu opcji zaawansowanych ma spore możliwości - pewnie kwestia ustawienia.
[Obrazek: VGWDZP9l.png]
Odpowiedz


Skocz do:




Użytkownicy przeglądający ten wątek: 1 gości